Digiprog3 mileage correction on 2004 530i help needed speedo malfunction - 5Series.net - Forums


E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 01-12-2018, 01:48 AM   #1  
New Members
Thread Starter
 
Join Date: Jan 2018
Location: Vancouver
Posts: 1
My Ride: 2004 BMW 530i
Default Digiprog3 mileage correction on 2004 530i help needed speedo malfunction

I bought a digiprog3 mileage correction tool and I attempted to correct the mileage backwards to test out if it works on BMWs as most people said BMW is hard to correct. Long story short after I put the cluster back in it reads 60,000kms when I programmed the eeprom chip I set it for 120,000kms the car originally had 130,000kms.... So the machine wrote it wrong..... So after I put it back in I get speedometer malfunction... Rpm guage comes on on start up then stops working.... Same with fuel guage not working..... My fuel guage is reading wrong as I put $60 of gas in after and it only went up to 75kms range and fuel guage stays low.... The speedometer and speed works..... But now it says dynamic drive malfunction, speedometer display malfunction, active steering malfunction, cruise control malfunction.

any help would be greatly appreciated thanks.

Last edited by Lotto786; 01-12-2018 at 01:51 AM.
Lotto786 is offline   Reply With Quote
Old 01-12-2018, 03:28 AM   #2  
New Members
 
Join Date: Dec 2012
Location: Montreal Quebec Canada
Posts: 306
My Ride: 2005 545i, premium package, 6sp manual, cold package, navigation package.
Model Year: 2005
Engine: N62
Default

Quote:
Originally Posted by Lotto786 View Post
I bought a digiprog3 mileage correction tool and I attempted to correct the mileage backwards to test out if it works on BMWs as most people said BMW is hard to correct. Long story short after I put the cluster back in it reads 60,000kms when I programmed the eeprom chip I set it for 120,000kms the car originally had 130,000kms.... So the machine wrote it wrong..... So after I put it back in I get speedometer malfunction... Rpm guage comes on on start up then stops working.... Same with fuel guage not working..... My fuel guage is reading wrong as I put $60 of gas in after and it only went up to 75kms range and fuel guage stays low.... The speedometer and speed works..... But now it says dynamic drive malfunction, speedometer display malfunction, active steering malfunction, cruise control malfunction.

any help would be greatly appreciated thanks.
Not sure why you want to do this, nor if its legal, but I doubt that you will get any help here.
FormerE30Owner is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 545i speedo dash problem james69z28 E60 Discussion 2 06-07-2013 02:17 AM
Crazy mileage when idling. Mileage meter malfunctioning? kreveta E60 Discussion 5 01-24-2011 03:43 PM
Will a OEM M5 speedo/tach Work well on a 2004 530i? Presley348 E60 Discussion 3 08-22-2010 04:38 PM
2004 bmw 530i 90k mileage tune up 530SOunds E60 Discussion 8 03-02-2009 07:53 PM
Higher mileage or lower mileage Techno79 E60 Discussion 17 08-25-2007 12:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 04:16 PM.


All content Copyright 2012 by Internet Brands, Inc.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.