E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

Transmission malfunctioning

Old 05-23-2019, 10:03 PM
  #1  
New Members
Thread Starter
 
Join Date: May 2019
Location: North Carolina
Posts: 4
My Ride: 04 545i
Default Transmission malfunctioning

I have a 04 545i and I've been getting the transmission malfunction message on my idrive where it says reduced acceleration I believe. Anyways sometimes the gear indicator doesnt show up on the dash it's just blank and the other day I was driving down the road and it's like it went into neutral by itself and today when I was just sitting there still in drive and it went from drive to reverse back to drive by itself without me moving the shifter. and this is an automatic transmission btw. what could be the cause of this?
Alex_Bro_Chill is offline  
Old 05-26-2019, 02:09 PM
  #2  
New Members
 
Join Date: Mar 2014
Location: NJ
Posts: 1
My Ride: 2009 528xi
Default

I have a 2009 528xi and I just started having the same exact issue.... and advice would be appreciated
ftcheech is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
EersNC
E60 Discussion
6
12-05-2010 09:02 PM
v_therussian
Private Member Classifieds
0
10-06-2010 11:03 PM
Fxdup5
E60 Parts, Accessories and Mods
0
10-19-2007 01:05 PM
rphman
E60 Discussion
5
12-05-2006 04:32 PM


Thread Tools
Search this Thread
Quick Reply: Transmission malfunctioning


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.