DIY: Do It Yourself Share all your DIY experiences here. Ask how-to questions also!

NCSExpert Code Mods

Old 01-09-2011, 10:39 PM
  #11  
Contributors
 
BLooD's Avatar
 
Join Date: Mar 2009
Location: Essex, UK.
Posts: 2,553
My Ride: 2006 530 d M-sport e60
Default

Have u got navigation?, if not u will have m.a.s.k instead.
BLooD is offline  
Old 01-10-2011, 03:11 AM
  #12  
Members
 
Join Date: Jan 2011
Location: Romania
Posts: 29
Default

Originally Posted by BLooD View Post
have you read any of this thread?
Yes i read it. I already did my BC_DIGITAL_V, VIDEO_DENY_C0B but for WELCOME LIGHT i did VA_WELCOMELIGHT and it appears in iDrive menu, but i can't activate it, i can select it, but in 1 second it is unselecting it self. In my FRM module i don't have anything about WELCOME LIGHT.
The strange thing is that when i read the hole car i find WELCOME_LIGHT nicht_aktiv, but i can't find it in individuals module to make it aktiv. Any ideas?

Please help. The car is e90 from 10.2006 and it has xonon lights with adaptive light, navigation (proffesional for EUROPE)and iDrive .
larry_bml is offline  
Old 01-10-2011, 06:49 AM
  #13  
Contributors
 
jay77's Avatar
 
Join Date: Aug 2009
Location: UK - Romford, Essex
Posts: 379
Default

Originally Posted by larry_bml View Post
Yes i read it. I already did my BC_DIGITAL_V, VIDEO_DENY_C0B but for WELCOME LIGHT i did VA_WELCOMELIGHT and it appears in iDrive menu, but i can't activate it, i can select it, but in 1 second it is unselecting it self. In my FRM module i don't have anything about WELCOME LIGHT.
The strange thing is that when i read the hole car i find WELCOME_LIGHT nicht_aktiv, but i can't find it in individuals module to make it aktiv. Any ideas?

Please help. The car is e90 from 10.2006 and it has xonon lights with adaptive light, navigation (proffesional for EUROPE)and iDrive .

On the E90 is the FRM the Light module? If so and you dont have the options your module needs to either be updated or you need a newer one. You can not get the option to work without coding the Light module as well.

On my E60 I do not have the option in my Light module so although I can enable it in idrive the car doesnt know what to do with the instruction, so unselects the option in idrive..from what you describe you can not enable the option unless you update the light module or a newer version of your light module.

Hope that helps..
jay77 is offline  
Old 01-10-2011, 08:01 AM
  #14  
Contributors
 
nomis_nehc's Avatar
 
Join Date: Jun 2009
Location: CA
Posts: 5,781
My Ride: BMW E60
Model Year: 2016
Default

Originally Posted by BLooD View Post
Have u got navigation?, if not u will have m.a.s.k instead.
No nav, and I actually had suspected this.

Sorry for being such a newb, but what does this mean since I have m.a.s.k? Do I have different steps to access the module?
nomis_nehc is offline  
Old 01-10-2011, 01:36 PM
  #15  
Contributors
 
BLooD's Avatar
 
Join Date: Mar 2009
Location: Essex, UK.
Posts: 2,553
My Ride: 2006 530 d M-sport e60
Default

Originally Posted by nomis_nehc View Post
No nav, and I actually had suspected this.

Sorry for being such a newb, but what does this mean since I have m.a.s.k? Do I have different steps to access the module?
No it`s the same, the CCC is made up of 5 parts and the m.a,s.k is the same.
BLooD is offline  
Old 01-10-2011, 01:50 PM
  #16  
Contributors
 
nomis_nehc's Avatar
 
Join Date: Jun 2009
Location: CA
Posts: 5,781
My Ride: BMW E60
Model Year: 2016
Default

Does that just mean I have no CAPPL then? That's so weird
nomis_nehc is offline  
Old 01-10-2011, 02:24 PM
  #17  
Contributors
 
nomis_nehc's Avatar
 
Join Date: Jun 2009
Location: CA
Posts: 5,781
My Ride: BMW E60
Model Year: 2016
Default

Btw Jim, I just wanted to point this out to you.

FL_UND_NSW_NICHT_GLEICHZ (Allow High beam and fog lamps on at same time)

is suppose to be nicht_aktiv to work.

Which will explain why it was already set to aktiv on mine and didn't work. I realized this when I pondered why it wasn't working and saw that there's a "nicht" - not - in the entry already.

Just coded it during lunch, and now it works. I imagine if someone is light crazy enough, they can install a HID kit in their high beams and make it... SUPER BRIGHT! Everyone on the road would hate that person though, lol. It's something the bixenon people can't do: low beam, high beam, and fogs all on at the same time
nomis_nehc is offline  
Old 01-10-2011, 06:12 PM
  #18  
Senior Members
Thread Starter
 
NoQuarter's Avatar
 
Join Date: Oct 2009
Location: Indiana, USA
Posts: 1,366
My Ride: 2007 530xi: Sport, NAV, PDC, HUD, Cold Wthr, CA, Logic 7, HD Radio, SAT, Custom NCS coded options 2008 535xi: Sport, Night Vision, NAV, PDC, HUD, Cold Wthr, CA, Logic 7, SAT, Custom NCS coded options, Rear Seat Heat Retrofit, Passport 9500ci
Model Year: 2008
Engine: N54
Default

Originally Posted by nomis_nehc View Post
Btw Jim, I just wanted to point this out to you.

FL_UND_NSW_NICHT_GLEICHZ (Allow High beam and fog lamps on at same time)

is suppose to be nicht_aktiv to work.

Which will explain why it was already set to aktiv on mine and didn't work. I realized this when I pondered why it wasn't working and saw that there's a "nicht" - not - in the entry already.

Just coded it during lunch, and now it works. I imagine if someone is light crazy enough, they can install a HID kit in their high beams and make it... SUPER BRIGHT! Everyone on the road would hate that person though, lol. It's something the bixenon people can't do: low beam, high beam, and fogs all on at the same time

Wow - I can't believe I missed that all this time. Sorry for all the confusion - at least there is an explaination for what you were seeing.

I can't edit any of those earlier posts - hope everyone sees this!

Correction...
FL_UND_NSW_NICHT_GLEICHZ (Allow High beam and fog lamps on at same time)
nicht_aktiv

NoQuarter is offline  
Old 01-10-2011, 10:54 PM
  #19  
Contributors
 
nomis_nehc's Avatar
 
Join Date: Jun 2009
Location: CA
Posts: 5,781
My Ride: BMW E60
Model Year: 2016
Default

Originally Posted by BLooD View Post
Have u got navigation?, if not u will have m.a.s.k instead.
Just kidding, figured it out. For non-navs it's in the MASK module (as you pointed out).
nomis_nehc is offline  
Old 01-11-2011, 12:16 AM
  #20  
Members
 
Join Date: Jan 2011
Location: Romania
Posts: 29
Default

Originally Posted by jay77 View Post
On the E90 is the FRM the Light module? If so and you dont have the options your module needs to either be updated or you need a newer one. You can not get the option to work without coding the Light module as well.

On my E60 I do not have the option in my Light module so although I can enable it in idrive the car doesnt know what to do with the instruction, so unselects the option in idrive..from what you describe you can not enable the option unless you update the light module or a newer version of your light module.

Hope that helps..
This may be problem, i called to a BMW service and they told me the same thing we though, the FRM module may need an update. I told them my VIN and they will try to find what update (if it can be made) need FRM for doing WELCOME LIGHT.

I will anounce you with their answer.
larry_bml is offline  

Thread Tools
Search this Thread
Quick Reply: NCSExpert Code Mods


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.