E60 from hell... - 5Series.net - Forums

E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

E60 from hell...

Old 01-11-2019, 02:19 AM
  #1  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Lakewood
Posts: 5
My Ride: E60 and itís junk
Default E60 from hell...

hello everybody! Iíve been wondering if someone could possibly give me some type of clue as to whatís going on with my car...

it all started when one day I came to my car being dead. Tried to turn it over and nothing. So I waited 30 minutes then tried again and it turned over but it was in limp mode. So I changed my battery it was good for 2 days then died again so I got a new battery. After the new battery it wouldnít turn over one night so I changed my fuel pump relay. That only worked for 2 days then it died again so I changed my
alternator. Drive it for about a day I come home to it smelling like burnt wires so I drive it just see what it is and it started popping codes my dash ways going crazy my car wouldnít stay on so now Iím sitting here scratching my eyes out trying to figure out why my car smells like burnt wires and doesnít run. ALSO BEFORE ALL THIS MY HORN RANDOMLY GOES OFF. yes my horn literally randomly goes off , doesnít matter if Iím sitting driving day/night cold/hot it goes off randomly and I noticed this before all this happened to my car... if someone could please tell me what to look for or do it would be a life saver!
Ifreezebmx562 is offline  
Old 01-11-2019, 02:22 AM
  #2  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Lakewood
Posts: 5
My Ride: E60 and itís junk
Default










Ifreezebmx562 is offline  
Old 01-11-2019, 03:31 AM
  #3  
Super Moderator
 
JayArras's Avatar
 
Join Date: Aug 2010
Location: Fairfield County, CT
Posts: 2,586
My Ride: 530xi
Model Year: 2007
Engine: N52
Default

Did you just acquire this vehicle? Where did you buy it? From your story, it sounds like a flood car that was restored. The electronics are the first thing to go haywire when they are exposed to water.
JayArras is offline  
Old 01-11-2019, 09:05 AM
  #4  
New Members
 
Join Date: May 2017
Location: Munich
Posts: 27
My Ride: 520iA; 2004; M54; 170HP; A08; ABAT; 1CA; 2RA; 205; 235; 320; 423; 428; 430; 431; 438; 459; 465; 494; 508; 534; 540
Default

There was a recall regarding the battery plus cable once. You should check this immediately especially if you do smell it already! If I remember correctly it was a worldwide recall because the plus cable got contact to the trunk cable inlet.

Could be just an IBS problem also but if you smell burned cables there ARE burning cables. Act fast!

All the codes are because of the voltage drop - don't worry.

Last edited by Giubo; 01-11-2019 at 09:10 AM.
Giubo is offline  
Old 01-11-2019, 10:37 AM
  #5  
New Members
 
Join Date: Jul 2018
Location: NJ
Posts: 18
My Ride: 535i X-Drive
Model Year: 2010
Default

Is your location Lakewood, NJ? It rained alot in NJ recently.

Have you checked your trunk to see if any water has collected in there and affected your electronic modules? They are located underneath the spare tire.
zoom750 is offline  
Old 01-11-2019, 01:37 PM
  #6  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Lakewood
Posts: 5
My Ride: E60 and itís junk
Default

Originally Posted by JayArras View Post
Did you just acquire this vehicle? Where did you buy it? From your story, it sounds like a flood car that was restored. The electronics are the first thing to go haywire when they are exposed to water.
Iíve actually had the car for about 4 years and no problems with it at all
Ifreezebmx562 is offline  
Old 01-11-2019, 01:38 PM
  #7  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Lakewood
Posts: 5
My Ride: E60 and itís junk
Default

Originally Posted by zoom750 View Post
Is your location Lakewood, NJ? It rained alot in NJ recently.

Have you checked your trunk to see if any water has collected in there and affected your electronic modules? They are located underneath the spare tire.
Iím Lakewood CA. And no I havnt checked my trunk! I will look right now!
Ifreezebmx562 is offline  
Old 01-11-2019, 01:41 PM
  #8  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Lakewood
Posts: 5
My Ride: E60 and itís junk
Default

Originally Posted by Giubo View Post
There was a recall regarding the battery plus cable once. You should check this immediately especially if you do smell it already! If I remember correctly it was a worldwide recall because the plus cable got contact to the trunk cable inlet.

Could be just an IBS problem also but if you smell burned cables there ARE burning cables. Act fast!

All the codes are because of the voltage drop - don't worry.
Iíve checked my vin to see if I have any recalls and I havenít seen anything. Iíll check again
Ifreezebmx562 is offline  
Old 01-17-2019, 03:08 AM
  #9  
New Members
 
Rookiemistake's Avatar
 
Join Date: Dec 2018
Location: Bucks County, PA
Posts: 7
My Ride: 2007 550i 6 speed steptronic
Model Year: 2007
Engine: 4.8
Default

Sounds like you have a short somewhere. your fuses, breakers, relays must be looked at. Do you have a Factory Service Manual?
Rookiemistake is offline  
Old 01-17-2019, 05:02 AM
  #10  
New Members
 
Join Date: Jul 2011
Location: Augusta, GA
Posts: 1,057
My Ride: None
Model Year: 05 530i
Engine: 3.0 M54
Default

What brand alternator did you get? Have it checked to makes sure it is not a bad alternator
seanjordan20 is offline  

Thread Tools
Search this Thread
Quick Reply: E60 from hell...


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.