Dangerous codes, engine shakes for only a minute on cold start, help please! - 5Series.net - Forums

Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > E60 Discussion
Reload this Page >

Dangerous codes, engine shakes for only a minute on cold start, help please!

E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

Dangerous codes, engine shakes for only a minute on cold start, help please!

Reply

 
 
 
Old 06-12-2018, 04:26 PM
  #1  
New Members
Thread Starter
 
Join Date: Jun 2018
Location: Tallahassee
Posts: 2
My Ride: 535i li sport DCI
Model Year: 2008
Default Dangerous codes, engine shakes for only a minute on cold start, help please!

Thanks in advance!

Car:

2008 bmw 535i lci n54 engine sport pkg in FL (temperature)

Codes:

Misfire all 6 cylinders

O2 sensors and heat monitors

EVAP

Purge Flow

Cats

Symptoms:

Engine shakes concerningly for a minute on every cold start and lifters/valve chain is loud. Worst at noon after 15 minute drive and 4 hours sitting, so heat soak makes me think leaky injector. Kind of 'snaps' into place and smooths out and quiets down in about 60 to 90 seconds all of a sudden. Only cold starts, problem is gone if operating temp. No check engine light, no limp mode. At operating temp, Sometimes the idle rocks the car and sometimes it bounces the rpm from 600 to 900 back and forth, but only sometimes

Context:

Occured after I changed oil cooler and filter housing gasket and bleed and flushed coolant (zero experience, didnt use battery charger even though DIY videos recommended to) and injector and fuel treatment

Ruled out:

Spark plugs, walnut blast/carbon/, valve cover gasket leak

Suspects:

1. Leaky injector(s)





2. Battery, IBS or DMB (battery good under load and alternator voltage, low 12.3 standing voltage)





3. PCV system





4. Coils





5. Vanos or Eccentric cam sensor





6. Thermostat





7. HPFP, LPFP, fuel pressure regulator





8. vaccum leak (horrible wastegate)





9. Motor mount





10. Air/fuel sensor





11. Foreign object in engine



Can yall help me rule anything out?

Thanks!
Jackson Kemper is offline  
Reply With Quote
Old 06-16-2018, 02:16 AM
  #2  
New Members
 
cmyachtie's Avatar
 
Join Date: Sep 2012
Location: Halifax, Nova Scotia, Canada
Posts: 377
My Ride: 2004 545i+BT+AUX+Coding
Model Year: 2004
Engine: N62
Default

If misfires are on all injectors doubt if they are all leaking all of a sudden, also battery seems ok.
First I’d do a vacuum test (smoke test or what). Maybe a vacuum leak or fuel delivery problem.
Any of the sensor you have listed should throw their own codes.

Am not to familiar with the 535 but I am chasing random misfires on my 545 only in winters though....
HTH
cmyachtie is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gamblinfool
E60 Discussion
0
02-22-2017 09:26 AM
nazboy84
E60 Discussion
16
05-26-2014 09:12 PM
elie7
E60 Discussion
12
03-29-2012 04:54 PM
ponnu
E60 Discussion
9
03-29-2009 11:13 AM
HOMEP1
E60 Discussion
10
11-17-2007 02:14 PM


Thread Tools
Search this Thread