E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

2008 528xi Jerks when accelerating

Old 07-09-2019, 07:43 AM
  #1  
New Members
Thread Starter
 
Join Date: Jun 2019
Location: Ontario
Posts: 3
My Ride: 2008 528XI, Silver, Tiptronic Trans, AWD, Premium sound system, Matte black rims, black accents, 10% tint, K&N Cold air intake,
Model Year: 2008
Engine: 3.4L inline 6
Unhappy 2008 528xi Jerks when accelerating

Hey everyone, its my first thread ive started because ive been going crazy on this problem,
I bought my first car 2 months ago, an e60 528xi.
Ive had to replace many things already which I expected, but now im at a loss here with the problem.
When I accelerate, not necessarily from a complete stop, the car jerks quite strongly, it kinda feels like something is slipping then it catches, then does it multiple times in one acceleration, I was told my a mechanic that it was misfiring and to change the coils, so while I was somewhat sure that it was a more mechanical problem because it felt like it, I changed them with new bosch coils, Even tho the car idles and revs just fine,
There are no codes according to my Carly for bmw
I replaced the transfer case motor recently and the prop shaft had some play in it when I bought it ( 2 months) according to mechanic
If anyone knows what the problem is or any suggestions would be greatly appreciated.
I looked on youtube and did so much research my head is wrapped up. everyone seems to have different suggestions. I wish theres just a way to tell what the problem is ( Also if its okay to drive with it)
Im sorta on a tight budget atm which is why I haven't taken it to a mechanic yet.
Thanks in advance

Last edited by Ben528xi; 07-09-2019 at 07:46 AM.
Ben528xi is offline  
Old 07-09-2019, 05:00 PM
  #2  
New Members
 
Join Date: Dec 2018
Location: Michigan, USA
Posts: 43
My Ride: 2009 528i xdrive
Default

When was the last time you fully serviced the transmission? Did you fill the fluid with the engine running? Did you replace the five rubber sleeves?
tstiglich is offline  
Old 07-09-2019, 06:24 PM
  #3  
New Members
Thread Starter
 
Join Date: Jun 2019
Location: Ontario
Posts: 3
My Ride: 2008 528XI, Silver, Tiptronic Trans, AWD, Premium sound system, Matte black rims, black accents, 10% tint, K&N Cold air intake,
Model Year: 2008
Engine: 3.4L inline 6
Default

Originally Posted by tstiglich View Post
When was the last time you fully serviced the transmission? Did you fill the fluid with the engine running? Did you replace the five rubber sleeves?
Hello. So Iíve only had the car for two months so no I havenít touched the tranny and I donít know any history on the tranny. Ik that the ďlifetimeĒ oil isnít actually lifetime. Also I didnít know anything about 5 rubber sleeves?
Ben528xi is offline  
Old 07-09-2019, 07:16 PM
  #4  
New Members
 
Join Date: Dec 2018
Location: Michigan, USA
Posts: 43
My Ride: 2009 528i xdrive
Default

Here is a general video for fluid replacement.
tstiglich is offline  
Old 07-09-2019, 07:18 PM
  #5  
New Members
 
Join Date: Dec 2018
Location: Michigan, USA
Posts: 43
My Ride: 2009 528i xdrive
Default

Here is one that details the rubber sleeves. 4 clyindrical, one rectangular.
tstiglich is offline  
Old 07-09-2019, 07:19 PM
  #6  
New Members
 
Join Date: Dec 2018
Location: Michigan, USA
Posts: 43
My Ride: 2009 528i xdrive
Default

Make sure the engine is running when you top off trans fluid. should be about 7 liters. double, triple torque all screws as the rubber compresses.
tstiglich is offline  
Old 07-09-2019, 07:21 PM
  #7  
New Members
 
Join Date: Dec 2018
Location: Michigan, USA
Posts: 43
My Ride: 2009 528i xdrive
Default

BMW maintenance intervals suck. Lifetime fluid means until your transmission fails. ZF recommends 60k miles.
tstiglich is offline  
Old 07-13-2019, 10:45 AM
  #8  
New Members
 
Join Date: Mar 2017
Location: Northeast Ohio, Greater Cleveland Area
Posts: 12
My Ride: '08 535xiT, No Mods
Model Year: 2008
Engine: N54
Default

Do you have an idea of where in the rev range this behavior is occurring? I've been having a similar issue with my '08 535xi wagon and it took a while before it threw any codes. I get a stutter that feels just like a misfire from around 3-4K RPM. Its not gear changes, and its not slippage as far as we can tell. My Indy looked at it and thinks it is a VANOS gear issue, which is inside the engine, rather than a simple solenoid. He is also suggesting at least plugs, and coils, and possibly injectors. Initially we were suspecting a Xfer case actuator but with the engine codes it eventually gave, the engine became the point of focus. At this point I'm driving it with the expectation of more codes to guide my mechanic. Good luck tracking it down and If you find a solution to your dilemma please be sure to post it here for the benefit of all.

Thanks!
Dad-E-Wagon is offline  
Old 07-14-2019, 08:38 AM
  #9  
New Members
 
Join Date: Jul 2018
Location: Michigan
Posts: 9
My Ride: 2007 530xi not sure on options think it is fully loaded
Model Year: 2007
Default

Reading what you have said about your car jerking and shifting hard. Sounds like a dirty Valve Body spools hanging up or weak solenoids. Matthew Cole,s Company can do the rebuild. of the VB (513) 886-1215

NOTE to the Forum
I am not a BMW professional but a self made auto mechanic. I just went through a Valve Body rebuild due to a transmission failure. I am now stuck with: Key in ignition, Sterling Angle sensor need reset . Car will not start or run, I hooked up a cheep code reader to try to remove faults but it didn't do anything. I don't know if the repair is good. Here is my question to the Forum does anyone live in the Genesee township of Flint Michigan that has a computer code checker that they would connect to my car to clear faults The car's message center is saying that a Steering lock is in-place but will not respond to my turning the steering wheel back and fourth
Michaelmajorana is offline  
Old 07-15-2019, 05:36 AM
  #10  
New Members
Thread Starter
 
Join Date: Jun 2019
Location: Ontario
Posts: 3
My Ride: 2008 528XI, Silver, Tiptronic Trans, AWD, Premium sound system, Matte black rims, black accents, 10% tint, K&N Cold air intake,
Model Year: 2008
Engine: 3.4L inline 6
Default

Hey everyone thank you for your feedback. Ive taken them all into account and so far what ive done is replaced the coils with new Bosch ones, and im in the process of replacing the valve cover gasket ( not related to this just needed to be done) and after that I will be replacing the spark plugs with new Bosch ones which my mechanic suggested. fingers crossed, he seemed sure it was the plugs and ill be realy happy if it is. will keep you all updated
thanks
Ben
Ben528xi is offline  

Thread Tools
Search this Thread
Quick Reply: 2008 528xi Jerks when accelerating


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.