F10 Discussion Anything and everything to do with the F10 5 Series. The F10 made it's debut in 2010 as a MY2011.

Electrical Burning Smell

Old 11-06-2015, 06:03 PM
  #1  
Members
Thread Starter
 
fifthinarow's Avatar
 
Join Date: Jan 2008
Location: Somerset.UK
Posts: 50
My Ride: december 2011 525d SE
Default Electrical Burning Smell

Help and information wanted please! My Dec 2011 525d (218) has developed an electrical burning smell from the central armrest where the usb and aux connections and the Bluetooth adaptor are. Ive only noticed it over the past few days and only traced where it was coming from today. Nothing has been plugged in there since I updated the audio software over a year ago and that went smoothly. I tried updating the software via the usb port today and nothing happened. On the idrive screen under updating the software it said there was no usb device connected although there clearly was. Has anybody else come across this or had electrical problems in the center armrest.
fifthinarow is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ranger530i
Private Member Classifieds
5
11-08-2015 07:33 AM
navtool.com
E39 Discussion
0
10-31-2015 04:18 PM
PelicanParts.com
Vendor Classifieds
0
10-20-2015 11:20 AM
Steve Naples
E60 Discussion
3
10-15-2015 08:22 AM


Thread Tools
Search this Thread
Quick Reply: Electrical Burning Smell


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.