530i - rough idle + stalling when hot/hot weather - 5Series.net - Forums

Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > E60 Discussion
Reload this Page >

530i - rough idle + stalling when hot/hot weather

E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

530i - rough idle + stalling when hot/hot weather

Old 01-07-2019, 09:06 PM
  #1  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Sydney, Australia
Posts: 5
My Ride: 2008 530i M Sport
Default 530i - rough idle + stalling when hot/hot weather

Hi All
first post here after a high number of searches, but nothing like mine...anyway... hope you guys can help !
2008 530i (i assume it is the N53 engine)

Symptoms: Engine idle hunting very roughly, shaking the whole car and stalling
Conditions: Only on extremely hot days/when driving for awhile (45+ minutes) and very hot weather. Does not occur when engine is cold.

Additional Symptoms: May not be related, but i also have a strong smell of petrol/exhaust fumes in the cabin, which leads me to believe i potentially have a cracked manifold or maybe leaking exhaust manifold gasket...not sure if related though.

I have had a few looks in the engine and underneath and i do have some oil leakage/seepage... can't see from where though.
any thoughts ? a few of my friends have advised it could be a vaccum leak, but if that is the case, why does it happen only when hot ? possible heat expansion of metal causing the leak...therefore only occurs when extremely hot ?

any help or experiences would be great...

thanks guys !!

Geoff
geo41e is offline  
Old 01-10-2019, 02:05 PM
  #2  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Sydney, Australia
Posts: 5
My Ride: 2008 530i M Sport
Default

bump

nothing guys ? lol i was hoping some sort of direction or FYI lol
geo41e is offline  
Old 01-10-2019, 06:29 PM
  #3  
New Members
 
Join Date: Jul 2011
Location: Augusta, GA
Posts: 998
My Ride: None
Model Year: 05 530i
Engine: 3.0 M54
Default

Do a smoke test. Check spark plugs. Never rule out leak if you have not checked it.
seanjordan20 is offline  
Old 01-13-2019, 02:14 PM
  #4  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Sydney, Australia
Posts: 5
My Ride: 2008 530i M Sport
Default

took it to the mechanic for a quick look.
there is a small leak from the rocker cover..though he says this shouldn't be the problem.
he says it is most likely the PCV or CCV opening either too much or leaking when really hot.

part isn't too much but labour.... he says it is abit of a pain to get to...
geo41e is offline  
Old 01-14-2019, 03:48 PM
  #5  
New Members
 
Join Date: Jul 2011
Location: Augusta, GA
Posts: 998
My Ride: None
Model Year: 05 530i
Engine: 3.0 M54
Default

Can you turn a wrench if so just doing yourself. Those are known for going bad. It will take a half a day if you don't know what you are doing. There are plenty of videos on YouTube to follow. Also I would change all the vacuum hoses while I'm doing it
seanjordan20 is offline  
Old 01-15-2019, 01:48 PM
  #6  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Sydney, Australia
Posts: 5
My Ride: 2008 530i M Sport
Default

umm

used to be a mechanic and still have all my tools..
but how do i know this is the issue ? i'm not the type to just try and see if this is the issue...

havn't seen any other people having the same symptoms as me... i mean...just doesn't make sense.
only happens when very very hot....crazy idle/hunting then stalls...
geo41e is offline  
Old 01-15-2019, 05:49 PM
  #7  
New Members
 
Join Date: Jul 2011
Location: Augusta, GA
Posts: 998
My Ride: None
Model Year: 05 530i
Engine: 3.0 M54
Default

You can have someone troubleshoot on your dime or see for yourself. If you are a mechanic it should go a lot quicker. Have you pulled any codes

I had something similar a few years back. It would stumble every once in a while. Read a few threads and took a dive to see if it was the issue sure enough the elbow cracked on mine. I also read that the hose would be brittle and crank while taking things apart so I bought and replaced them also.
seanjordan20 is offline  
Old 01-16-2019, 07:02 PM
  #8  
New Members
Thread Starter
 
Join Date: Jan 2019
Location: Sydney, Australia
Posts: 5
My Ride: 2008 530i M Sport
Default

awesome advice Sean

i havn't pulled any codes yet, and the engine light did come on once...but not during the stutter/stall... funny enough it came on when i was going down hill..with abit of acceleration... then it went away...
i'll try pull some codes tonight as i do have an ultraguage...see if that works
geo41e is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kvlar78
E60 Discussion
2
10-24-2018 07:02 AM
pjinca
E60 Discussion
6
02-25-2013 04:44 PM
HiOffcr
E60 Discussion
5
02-26-2011 11:57 PM
zakattak20
E60 Discussion
0
10-14-2009 09:56 PM


Thread Tools
Search this Thread
Quick Reply: 530i - rough idle + stalling when hot/hot weather


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.