E39 Discussion Anything and everything to do with the E39 (1997 - 2003) 5 series!

Homelink/Garage Opener fuse keeps blowing #21

Old 05-30-2011, 04:47 PM
  #1  
Members
Thread Starter
 
Join Date: Dec 2007
Posts: 5
Default

i tried to retrofit a homelink unit on my 99 528it, but for some reason the circuit for the garage opener keeps blowing out. its fuse #21, 5amp.

its not the homelink unit, bc a new fuse will blow when the ignition is switched on even without the Homelink connected (which is also the reason why i dont think its the ground wiring).

im guessing the hot wire (green/white) is shorting somewhere...

1. anyone experience this before?

2. is there some specific place where wiring is known to get worn out/exposed, over time due to wear and tear?

3. could be something else? maybe something related to the ignition, since that power is switched 12v?

i know i could just run a new switched power wire up to the unit, but ill let that be the last resort. id rather fix it properly...
adrce55 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Bounce
Private Member Classifieds
2
08-31-2015 10:04 AM
Magnus_B
E60 Discussion
3
08-10-2015 05:55 AM
tommyboy
E60 Discussion
7
08-03-2015 03:06 PM
e60_simr
E60 Discussion
0
07-29-2015 02:35 PM
hmilycar
E60 Discussion
1
07-07-2015 12:29 PM


Thread Tools
Search this Thread
Quick Reply: Homelink/Garage Opener fuse keeps blowing #21


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.