E39 Discussion Anything and everything to do with the E39 (1997 - 2003) 5 series!

1997 523i acceleration delay

Old 02-13-2011, 12:53 AM
  #1  
Banned
Thread Starter
 
Join Date: Aug 2010
Posts: 125
Default

I drive a 1997 BMW 523i with steptronic transmission and have a problem that annoys me. When I drive at a speed of around 40km/h and want to accelerate a bit, the car doesn't respond at all. I have to press the acceleration pedal to the end, and just then the car accelerates but as you understand the acceleration isn't smooth and makes the passengers feel a bit uncomfortable. As far as I know BMWs suffer from such kind of a lag. But if it was so, nobody would buy BMW. So I think there is a problem with my car.
Can anybody help me on this issue?
Thanks
BabkenBMW is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
andymax
E60 Discussion
12
05-20-2018 11:32 AM
MarkOanes
E60 Discussion
22
10-25-2015 09:23 AM
Katitu
E60 Parts, Accessories and Mods
0
09-28-2015 11:22 AM
ST JAMES
E60 Discussion
6
09-04-2015 04:54 PM
teerapote
E60 Discussion
6
08-26-2015 05:24 AM


Thread Tools
Search this Thread
Quick Reply: 1997 523i acceleration delay


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.