Samsung Galaxy S9 Bluetooth Audio problem - 5Series.net - Forums

Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > Bluetooth & Cell Phone Forum
Reload this Page >

Samsung Galaxy S9 Bluetooth Audio problem

Bluetooth & Cell Phone Forum Have a bluetooth or mobile/cellular phone issue or question? Your answer will be here!

Samsung Galaxy S9 Bluetooth Audio problem

Old 10-22-2018, 07:25 PM
  #1  
Members
Thread Starter
 
Join Date: Nov 2008
Location: Sydney, Autralia
Posts: 111
My Ride: E60 530d M Sport, Alpine White, 2006, Australian
Model Year: 2005
Default Samsung Galaxy S9 Bluetooth Audio problem

Hello,

I'm having a problem using a brand new Samsung Galaxy S9 on my 2005 E60. The phone paired ok with the car. The car is fitted with the standard business navigation and audio pack, not the professional. There is no usb in the car.

When I make calls the audio is bad. I can hear what people say, but they sound like a robot or Darlek from Dr Who. People say they can hear me crystal clear. I was wondering if anyone else has had a similar experience. I suspect it has something to do with the Bluetooth V5.0 on the S9.

For the last 5 years I've been using a Galaxy S5, which worked fine. Before that, an S2.

Any ideas?

Thanks in advance.

virgil
virgil is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tex_phil
Private Member Classifieds
0
06-04-2011 07:44 PM
Persian_535i
Private Member Classifieds
17
10-04-2010 09:47 PM
Persian_535i
Bluetooth & Cell Phone Forum
1
09-22-2010 01:03 PM


Thread Tools
Search this Thread
Quick Reply: Samsung Galaxy S9 Bluetooth Audio problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.