Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > E61 Touring Discussion
Reload this Page >

Diversity antenna - comfort access and remotes not working

E61 Touring Discussion The touring is also known as the wagon version of the 5 series.

Diversity antenna - comfort access and remotes not working

Old 09-21-2018, 01:41 PM
  #1  
New Members
Thread Starter
 
Join Date: Feb 2015
Location: canada
Posts: 44
My Ride: 535xit
Model Year: 2008
Default Diversity antenna - comfort access and remotes not working

My remotes stopped working. No control access and no keyless start.
I opened up the rear spoiler just to find the diversity antenna corroded due to moisture and water ingress.
I have checked all my fuses and all seems fine. I have not tested the wiring to the module yet.
a replacement part is 600$ at my local dealership.

Does it require to be programmed once installed or is it a plug and play unit?
Can I fit an used one if I find it? can this modules be repaired?

thanks

corrosion

box
!
zenocchio is offline  
Old 09-23-2018, 01:35 PM
  #2  
Members
Senior Members
 
KyleB's Avatar
 
Join Date: May 2012
Location: Tampa Bay, FL
Posts: 2,538
My Ride: 530i
Model Year: 2004
Engine: M54
Default

Diversity antenna should be plug and play. good luck.
KyleB is offline  
Old 09-26-2018, 01:56 AM
  #3  
New Members
 
Join Date: May 2013
Location: Montreal
Posts: 73
My Ride: 2010 535xiT Touring
Model Year: 2010
Engine: N54 3.0L Twin Turbo
Default

You can get these on eBay for about $125 - the E63 modules are more common and cheaper - the only difference with an E63 module is that it has captive mounting screws instead of nuts - but you can just switch them out with the antenna you've pulled. The E63 part number is 6934485. Good luck.
gman6262 is offline  
Old 09-26-2018, 02:08 AM
  #4  
New Members
 
Join Date: May 2013
Location: Montreal
Posts: 73
My Ride: 2010 535xiT Touring
Model Year: 2010
Engine: N54 3.0L Twin Turbo
Default

I just checked on eBay - there's a few active listings for the E63 module for $25 to $75 - you're in luck.
gman6262 is offline  
Old 10-02-2018, 02:11 PM
  #5  
New Members
Thread Starter
 
Join Date: Feb 2015
Location: canada
Posts: 44
My Ride: 535xit
Model Year: 2008
Default

thanks!
replaced and all is good now!
zenocchio is offline  
Old 04-06-2019, 01:34 PM
  #6  
New Members
 
quattromeister's Avatar
 
Join Date: Oct 2014
Location: Seattle
Posts: 49
My Ride: 535xi wagon
Model Year: 2008
Engine: N54
Default

My antenna went out. Strange no water damage. I have a '08 535xi wagon with comfort access, will this work?
Thanks in advance
quattromeister is offline  
Old 04-06-2019, 05:45 PM
  #7  
New Members
 
Join Date: Aug 2018
Location: Abbotsford, BC
Posts: 99
My Ride: 535xi wagon 6MT
Model Year: 2009
Engine: N54
Default

Originally Posted by quattromeister View Post
My antenna went out. Strange no water damage. I have a '08 535xi wagon with comfort access, will this work?
Thanks in advance
Itís worth a shot. Iím debating the same thing. Really grateful that you guys mentioned the E63 being cheaper because these things for E61ís are quite pricey on eBay. Could also be a broken wire going through the hinge.
kd7iwp is offline  
Old 04-08-2019, 08:47 PM
  #8  
New Members
 
Join Date: Aug 2018
Location: Abbotsford, BC
Posts: 99
My Ride: 535xi wagon 6MT
Model Year: 2009
Engine: N54
Default

Tonight tried debugging a few things and didnít get very far. With INPA I was monitoring the antenna field strength while doing various tests but saw no issues.
  • Unplugging the coaxial cable from the antenna amplifier (FBD) caused INPA to report the connection to the FBD was faulty. Radio reception decreased dramatically. Remote keys would not work at all.
  • Unplugging the power cable to the FBD caused it to say connection was faulty and radio reception decreased dramatically. Remote keys would not work at all.
  • Unplugging 3 pin rear window antenna cable from FBD caused marginal drop in signal strength. Touching pieces of wire to the 3 FBD pins made a bit of a difference (basically making my own antenna).
  • Unplugging the diversity antenna (inside rear spoiler) caused remote keys to not work and a dramatic loss in AM reception.

All this to say, seems like everything is working as it should. I would assume a bad FBD would show little to no decrease in performance when unplugged.

One interesting thing to note is that on FM my radio reception increased when I disconnected a little 2-wire black plug to the right of the FBD. Not sure what that goes to. Reception went from 12/15 to 8/15 repeatedly.

I did notice that one of our two keys has vastly better range than the other. Swapping batteries did not transfer the range to the other key. My wife uses that other key normally and she said it usually works ok, sometimes has to take it out of her purse and put on console to start the car.
kd7iwp is offline  
Old 04-26-2019, 02:30 PM
  #9  
New Members
 
Join Date: Aug 2018
Location: Abbotsford, BC
Posts: 99
My Ride: 535xi wagon 6MT
Model Year: 2009
Engine: N54
Default

Got an antenna amplifier from a 2008 6 series on eBay for $30 and it appears to have fixed all my problems! My other amplifier is date stamped 2015 and looks great, so not sure what failed. This one from 2007 is working great.
kd7iwp is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
E61 Touring Discussion
31
11-05-2018 02:55 AM
Rdougan
E61 Touring Discussion
9
02-18-2016 05:57 PM
msevestre
E61 Touring Discussion
16
11-17-2014 12:06 AM
cyril
E60 Discussion
14
04-15-2010 09:35 PM


Thread Tools
Search this Thread
Quick Reply: Diversity antenna - comfort access and remotes not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.