Clunking noise when I set my coils too low - 5Series.net - Forums


Reply
 
 
 
Thread Tools Search this Thread
Old 05-09-2017, 03:07 PM   #1
New Members
Thread Starter
 
Join Date: May 2017
Location: Colorado
Posts: 2
Default Clunking noise when I set my coils too low

So I just got ISC Coilovers for my 2008 535xi and I put them down fairly far, just so the fender was slightly lower than the top of the tire with stock wheels and tires, and now there is a clunking noise when I drive that increases with speed and continues when I am in neutral. I am pretty sure that it is axle bind because it went away once a raised the coils up. Once I get bigger wheels I am hoping it will not even happen when I get the coils set where I want them; but does anyone have any other ideas on how to fix this? Or know if it could be anything else? Thanks
liam_e60_535xi is offline   Reply With Quote
Old 05-16-2017, 08:53 AM   #2
New Members
 
Join Date: Jun 2013
Location: NyC
Posts: 105
Default

Did you replaced your strut mounts.
DILLESTJAMZ is offline   Reply With Quote
Old 05-16-2017, 11:35 AM   #3
New Members
Thread Starter
 
Join Date: May 2017
Location: Colorado
Posts: 2
Default

You mean the collars that pinch around the bottom of the strut? No I didn't they're part of the main hub piece. The problem is only on the front by the way, I forgot to mention that in my earlier post.
liam_e60_535xi is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 02:26 PM.


All content Copyright 2012 by Internet Brands, Inc.