E60 Help [Instrument Cluster] - 5Series.net - Forums

Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > E60 Discussion
Reload this Page >

E60 Help [Instrument Cluster]

E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

E60 Help [Instrument Cluster]

Reply

 
 
 
Old 08-07-2018, 12:32 PM
  #1  
New Members
Thread Starter
 
Join Date: Aug 2018
Location: New York
Posts: 2
My Ride: 525I Cigar interior
Model Year: 2004
Question E60 Help [Instrument Cluster]

All of the sudden my instrument cluster stopped working, I can use my Blinker and hazards but the display is none existent and my RPM and speedometer does not work either.

- Tried looking to see if rodents got in anywhere but there's no signs
- Replaced all the fuses
- Took of battery and hooked it back up an hour later
Any help would be much appreciated
Robert Alford is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
joss525
E60 Discussion
4
01-22-2011 12:47 PM
awboy
E60 Discussion
7
05-03-2009 11:09 AM
Kuiper545i
E60 Parts, Accessories and Mods
8
04-24-2007 06:58 AM


Thread Tools
Search this Thread
Quick Reply: E60 Help [Instrument Cluster]


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.