E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

e60 530d 2004 automatic transmission problem

Old 05-03-2019, 12:52 AM
  #1  
New Members
Thread Starter
 
Join Date: May 2019
Location: macedonia
Posts: 2
My Ride: e60 530d
Model Year: 2004
Default e60 530d 2004 automatic transmission problem

Hi to all,I own e60 530d from 2004,so far Im more than satisfied,no problems at all,only regular services.Recently a problem appeared,usually when the car is cold,not driven,first 15-20km when I drive with constant speed arround 70-80km/h rpm is moving up and down like it wont lock to one speed and there is some sound also,if I drive slower throug city this there is no problem.If I add throtle it shifts normally,only if I drive on same constant speed I have this issue.After some time when gearbox became warm enough(only my oppinion)car is shifting normally with no problem at all.If I drive in sport mode(which keeps rpm higher) there is no problem even when the car is cold.Can someone help me and tell me what is the problem?TMaybe torque converter as I read posts or I saw on net some rubber seals (4 pieces,three long like tubes and one like two squares) needs to be replaced or something else?
Sorry if my english is not quite correct.
Thanks!
dejan.s is offline  
Old 05-03-2019, 02:22 PM
  #2  
New Members
 
Join Date: Sep 2013
Location: Kansas City
Posts: 18
My Ride: 530Xi Touring
Model Year: 2006
Default

Have you had the Transmission fluid flushed with new ZF-Life Guard 6 Fluid? The fluid needs to be changed due to the tight tolerances of the Transmission. The ZF transmission is a great design. Lets start there.
Tetonfiber is offline  
Old 05-04-2019, 12:21 PM
  #3  
New Members
Thread Starter
 
Join Date: May 2019
Location: macedonia
Posts: 2
My Ride: e60 530d
Model Year: 2004
Default

Thanks for your opinnion,I bought this car from friend,so he told me that he has already changed the oil and oil filter,but not with genuine one,some other oil brand.He say that maybe first km gearbox was acting little beter than before,didnt doing that rpm variation often, but after some time again same behavior.Im suspecting on oil or that rubber seals between mechatronic panel and gears,if it is up to torque converter I think it will performe same on cold and warm gearbox.In my case this happens only on cold gearbox lets say,after drivin the car for maybe 20-25 km problem is gone,gearbox works perfectly!!!
I will try to find genuine fluid in my place if it is possible and replaced again.
Than you friend!
dejan.s is offline  
Old 05-14-2019, 12:38 AM
  #4  
New Members
 
Join Date: May 2019
Location: El Paso, Santa Cruz de La Palma
Posts: 2
My Ride: Bmw 530iSE
Model Year: 2004
Engine: M54
Default

Hi, I recently had a similar issue with a 530i on a trip across Europe, towing an 1100kg trailer which included driving up a steep mountain road, where the car warned me to stop as the transmission fluid had got too hot, perfect for a spot of lunch. The revs were ‘hunting’ in every gear, seems to climb around 500 revs and drop constantly. I ended up driving with manual up changes. I have just changed he rocker cover gasket due to it hardening with age and leaking, found the underside of the car is covered in oil, i’m Suspecting it to be the transmission fluid as now found that it is reluctant to change gears automatically at all, although manually it will. Have seen that the mechatronic electronics sleeve leaks and wonder if fluid loss is the cause. I’m going to replace the filter, fluid and internal mechatronic sleeves while it is apart as the car is 15 years old now. Any other pointers would be great. I am going to spend the extra and replace with genuine ZF and Lifeguard 6

Last edited by JCapirote; 05-14-2019 at 12:39 AM. Reason: Adding information
JCapirote is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ked263
E60 Parts, Accessories and Mods
2
02-11-2013 12:44 PM
EHowe12
E60 Discussion
0
09-28-2007 03:36 PM
tri
E61 Touring Discussion
13
10-09-2006 01:24 PM
Håkon
E60 Discussion
11
05-24-2006 07:41 AM
oreo
E60 Discussion
3
10-03-2005 04:57 AM


Thread Tools
Search this Thread
Quick Reply: e60 530d 2004 automatic transmission problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.