E60 Discussion Anything and everything to do with the E60 5 Series. All are welcome!
Sponsored by:
Sponsored by:

5 Series BMW Windscreen wipers

Old 04-14-2019, 06:28 AM
  #1  
New Members
Thread Starter
 
Join Date: Apr 2019
Location: ireland
Posts: 1
My Ride: 5 series BMW
Default 5 Series BMW Windscreen wipers

hi I have a 2008 5 series BMW M sport, the wipers have stopped working in the upwards position, I have already replaced the fuses the brown relay switch and the wiper motor and wiper switch but it's still not working, does anyone know how to fix the issue? thanks in advance, Fergus
fergusmcc is offline  
Old 04-17-2019, 07:32 PM
  #2  
Senior Members
 
NoQuarter's Avatar
 
Join Date: Oct 2009
Location: Indiana, USA
Posts: 1,366
My Ride: 2007 530xi: Sport, NAV, PDC, HUD, Cold Wthr, CA, Logic 7, HD Radio, SAT, Custom NCS coded options 2008 535xi: Sport, Night Vision, NAV, PDC, HUD, Cold Wthr, CA, Logic 7, SAT, Custom NCS coded options, Rear Seat Heat Retrofit, Passport 9500ci
Model Year: 2008
Engine: N54
Default

Hi Fergus

I also have a 2008 535 and have not seen anything like you describe. Do you have any new information on this problem yet?
NoQuarter is offline  
Old 05-25-2019, 09:46 PM
  #3  
New Members
 
Johnny 5 Bimmer's Avatar
 
Join Date: Jul 2017
Location: United States
Posts: 11
My Ride: E60 2010 535i /FBO
Model Year: 2010
Default Wipers issue

Originally Posted by fergusmcc View Post
hi I have a 2008 5 series BMW M sport, the wipers have stopped working in the upwards position, I have already replaced the fuses the brown relay switch and the wiper motor and wiper switch but it's still not working, does anyone know how to fix the issue? thanks in advance, Fergus

Had to get me a bee motor. Used 55 bucks. Install was a pain . Did the same ,fuse,relay... it's the motor most likely..unless u have have the wipers stuck in position. There is a you tube out there on how to to fix. Good luck
Johnny 5 Bimmer is offline  
Old 05-25-2019, 09:47 PM
  #4  
New Members
 
Johnny 5 Bimmer's Avatar
 
Join Date: Jul 2017
Location: United States
Posts: 11
My Ride: E60 2010 535i /FBO
Model Year: 2010
Default

Originally Posted by Johnny 5 Bimmer View Post
Had to get me a bee motor. Used 55 bucks. Install was a pain . Did the same ,fuse,relay... it's the motor most likely..unless u have have the wipers stuck in position. There is a you tube out there on how to to fix. Good luck

Sorry ,did not see u already got motor. Power getting there???
Johnny 5 Bimmer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sleeper
E60 Discussion
7
06-28-2007 11:59 PM
jurgen
E60 Discussion
15
04-11-2007 06:37 AM
rxlee
E60 Discussion
3
06-23-2006 06:41 PM
forge197
E60 Discussion
13
01-18-2006 02:44 PM
browellm
E60 Discussion
29
06-07-2004 05:24 AM


Thread Tools
Search this Thread
Quick Reply: 5 Series BMW Windscreen wipers


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.