Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > Bluetooth & Cell Phone Forum
Reload this Page >

IMPORTANT NOTICE FOR PEOPLE HAVING IPHONE SOUND PROBLEMS- **UPDATE**

Bluetooth & Cell Phone Forum Have a bluetooth or mobile/cellular phone issue or question? Your answer will be here!

IMPORTANT NOTICE FOR PEOPLE HAVING IPHONE SOUND PROBLEMS- **UPDATE**

Old 07-11-2007, 08:36 PM
  #1  
Contributors
Thread Starter
 
rodneyremington's Avatar
 
Join Date: Jul 2005
Location: Sunny California
Posts: 651
My Ride: 2005 545i with everything
Default

OK, sorry about the all caps, but this problem has been plaguing me since I got the iphone and I know I'm not alone. At least one other forum member has had an iphone with defective bluetooth hardware causing frequent sound drop-outs while speaking on the iphone via bluetooth through the car (in my case a 2005 545i). I tried every possible fix and finally read where another forum member exchanged his phone and the problem was fixed. Well I finally exchanged my phone today and the new phone works PERFECTLY with no drop-outs. The other phone was virtually unusable because of sound drop-outs although it paired fine. It also paired fine and sounded fine with a headset, it only had problems in my car.

This makes me think there is a problem with defective bluetooth hardware in some iphones.

EDIT-- well 24 hours after getting the new phone, the problem is back. Very frustrating. I did some more troubleshooting and there is a possibility that turning off the wifi corrects the problem. I need some more time to confirm this. It's possible that there is some interference between a search for wifi networks and the bluetooth connection with the car.
rodneyremington is offline  
Old 07-13-2007, 12:25 PM
  #2  
Members
 
Join Date: Nov 2005
Posts: 50
Default

Originally Posted by rodneyremington' post='446549' date='Jul 12 2007, 12:36 AM
OK, sorry about the all caps, but this problem has been plaguing me since I got the iphone and I know I'm not alone. At least one other forum member has had an iphone with defective bluetooth hardware causing frequent sound drop-outs while speaking on the iphone via bluetooth through the car (in my case a 2005 545i). I tried every possible fix and finally read where another forum member exchanged his phone and the problem was fixed. Well I finally exchanged my phone today and the new phone works PERFECTLY with no drop-outs. The other phone was virtually unusable because of sound drop-outs although it paired fine. It also paired fine and sounded fine with a headset, it only had problems in my car.

This makes me think there is a problem with defective bluetooth hardware in some iphones.

EDIT-- well 24 hours after getting the new phone, the problem is back. Very frustrating. I did some more troubleshooting and there is a possibility that turning off the wifi corrects the problem. I need some more time to confirm this. It's possible that there is some interference between a search for wifi networks and the bluetooth connection with the car.
I'm having the same problem. I've been searching the web trying to figure out if there were any known bluetooth issues then I decided that I need to come home to e60.net. Sometimes when I'm placing a call the ringing sound breaks up and then when a person answers I cant hear them until I call them back or until they call me. The audio problem has been a pain so I often end up talking on the phonme itself. I'm going to do some troubleshooting this weekend to see what I can find out.
nupe009 is offline  
Old 07-13-2007, 01:58 PM
  #3  
Members
 
Join Date: Nov 2005
Posts: 50
Default

One of my coworkers had the following to say about it:

I get a much better experience plugging in my iPhone to a car charger than just in the pocket. I have heard that the iPhone is very aggressive about power conservation and Bluetooth, and plugging it in helps alleviate that.

I'm going to test this out today.
nupe009 is offline  
Old 07-13-2007, 10:48 PM
  #4  
Contributors
Thread Starter
 
rodneyremington's Avatar
 
Join Date: Jul 2005
Location: Sunny California
Posts: 651
My Ride: 2005 545i with everything
Default

It's the wifi. I'm 95% sure of it. I can turn my wifi off in the car and the phone works perfectly. Turn it on, and 8 times out of 10 I get the sound dropout problem. So for now the fix is to turn off the wifi when I'm in my car. Not a huge deal but still not what it should be.

I have a 2005 545i with nav. Any ideas as to why there would be interference between the wifi and bluetooth audio coming in?
rodneyremington is offline  
Old 07-14-2007, 12:48 AM
  #5  
Contributors
 
Join Date: Nov 2005
Location: London, UK
Posts: 4,719
My Ride: BMW E60 520d SE Saloon M47 2.0dTitanium Grey II, Grey−Dakota Leather, Visibility Package, Media Package, Through Load System, Lumbar support − fr seats, Automatic Air Conditioning−Advanced, High beam assistant, Hi−Fi Loudspeak
Model Year: 2006
Default

Does the iPhone have the concept of profiles? Then you can make one for the car that turns off wifi and turns on bluetooth. When you leave simply switch it back to how you wanted it.
bruce_miranda is offline  
Old 01-11-2008, 09:19 AM
  #6  
Geo
Members
 
Join Date: Dec 2005
Posts: 59
My Ride: 530i
Default

Originally Posted by rodneyremington' post='447583' date='Jul 14 2007, 01:48 AM
It's the wifi. I'm 95% sure of it. I can turn my wifi off in the car and the phone works perfectly. Turn it on, and 8 times out of 10 I get the sound dropout problem. So for now the fix is to turn off the wifi when I'm in my car. Not a huge deal but still not what it should be.

I have a 2005 545i with nav. Any ideas as to why there would be interference between the wifi and bluetooth audio coming in?

I also have been having problems with the bluetooth connection. I finally toggled the WiFi during a call and noticed a huge difference in drop outs. I haven't yet tested to see if it only occurs when it detects a WiFi network in the area. If so, I will repost.
Geo is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
DavaiLave
E60 Discussion
12
04-14-2016 11:29 AM
YannickVT
E60 Discussion
0
05-07-2015 11:45 PM
das
Site Comments & Suggestions
0
09-05-2003 10:07 AM
Litster
Dealer Purchasing & Service Forum
2
08-12-2003 11:41 AM
Beemer
E60 Discussion
7
07-09-2003 05:38 PM


Thread Tools
Search this Thread
Quick Reply: IMPORTANT NOTICE FOR PEOPLE HAVING IPHONE SOUND PROBLEMS- **UPDATE**


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.