Go Back  5Series.net - Forums > E60 5 Series (2004 - 2010) > Bluetooth & Cell Phone Forum
Reload this Page >

03/04 to 08/04 BLUETOOTH CAN BE DONE WITH CODING! NO $$&

Bluetooth & Cell Phone Forum Have a bluetooth or mobile/cellular phone issue or question? Your answer will be here!

03/04 to 08/04 BLUETOOTH CAN BE DONE WITH CODING! NO $$&

Old 03-17-2012, 06:21 AM
  #21  
Members
Thread Starter
 
Join Date: Aug 2011
Location: Springboro, OH
Posts: 79
Default

Also, adding k633 to the VO and coding the car should do the trick.
brendinernst is offline  
Old 03-17-2012, 07:41 AM
  #22  
Members
 
jtmone's Avatar
 
Join Date: Nov 2010
Location: usa/md
Posts: 12
My Ride: 2004 545i - Black
Default

Originally Posted by brendinernst View Post
Also, adding k633 to the VO and coding the car should do the trick.
ok... Thanks so please confirm this is what I need to change .... And this is for US E 60 correct with US phones?

The following changes will need to be made in the TCU and MASK ? no NAV

---TCU---

BLUETOOTH
aktiv
PORTABLE_BT
aktiv

---MASK---

PHONE_MULF
aktiv
PHONE_BUSINESS
nicht_aktiv

PHONE_PROF
nicht_aktiv

BLUETOOTH_NODES_MASK
profil_2

Also, adding k633 to the VO and coding the car should do the trick
jtmone is offline  
Old 03-17-2012, 07:55 AM
  #23  
Members
Thread Starter
 
Join Date: Aug 2011
Location: Springboro, OH
Posts: 79
Default

Thats it. Try just changing the settings above first. That is what I did. i did not use k633 but that is what a lot of others have done. All I did was change the settings above and my bluetooth works perfectly.
brendinernst is offline  
Old 03-17-2012, 08:03 AM
  #24  
Members
 
jtmone's Avatar
 
Join Date: Nov 2010
Location: usa/md
Posts: 12
My Ride: 2004 545i - Black
Default

OK... Great I will get done on monday my friend is at the tract today .... Appreciate all your Help amigo ~~

Take Good Care

Mike
jtmone is offline  
Old 03-24-2012, 02:54 PM
  #25  
Senior Members
 
spediegunz's Avatar
 
Join Date: May 2011
Location: nyc
Posts: 807
Default

hey brendinernst i successfully did the tcu retrofit on my 04 with cic but i got 2 issues when I start the car i get an sos error popping up i don't know if thats from the new tcu and second even though my phone pairs and everything I can't control it with the car when i click on communication it says i have no phone installed and i must call bmw also i cant answer calls with my stearing wheel button i basically have to dial and answer and hangup from my phone i can't see my phone but or anything. I think the setting on this tcu has the bmw pro phone on as well maybe thats why i cant do anything how can i fix this issue?
spediegunz is offline  
Old 04-02-2012, 03:00 PM
  #26  
Members
 
Join Date: Aug 2008
Posts: 31
Default

Hi Brendinernst,

I have the factory ECE Motorola phone (SA638) installed in my E61 06/2004 together with CCC (Navi prof).
My VO has $638 and the only difference to the settings you wrote (and the other guy for CCC) is that PORTABLE_BT is set to nicht_aktiv.
Apparently the setting PHONE_PROF is nicht_aktiv, but my prof phone works.

So would only changing the parameter PORTABLE_BT to aktiv make it work, or I have to remove $638 and set $633 in my VO?
I just want it to behave as a BT hands-free kit to pair my iPhone with and use the steering wheel button and iDrive knob to make calls.

Best regards,
Straba
straba is offline  
Old 04-03-2012, 03:59 AM
  #27  
Senior Members
 
spediegunz's Avatar
 
Join Date: May 2011
Location: nyc
Posts: 807
Default

Im no expert on this but i remember reading some where you can only have one or the other working on I drive either the professional phone or a bt portable phone so maybe having them both on can cause conflicts. As far as what parameters you need to change to get your iPhone working maybe try the instructions I posted earlier. But before you make any changes back up your trace as you might make matters worse but its still worth a try. Also brendin also discovered these additional parameters and shared them with me which allowed me to see the phone book option instead of call BMW and let me get caller I'd and steering wheel control plus voice dialing commands. However my phone book still won't sync, but i hear its a common problem for android devices.

CAPPL:

PHONE_VERSION
no-phone

BLUETOOTH_NODES_CCC
profil_2

TELEFON_TYPE_C08
mulf_phone

I would try the first set of instructions before making changes to these addition parameters
spediegunz is offline  
Old 04-11-2012, 09:46 PM
  #28  
Members
Senior Members
 
Join Date: May 2011
Location: Montreal, QC
Posts: 271
My Ride: Bmw E60 530i 2004 Jet Black sport package on Linea Corse 19" Lc818 Saphire Black
Default

I`ve followed your instructions brendinernst, everything seems to work,I`ve paire my iphone with my car, but th only thing is that the car doesn`t sync my iphone contacts...so do you know how can I fix this

I`ve read somewhere that maybe I need to perform an update on the idrive..

what do you think


thanks
tgm001 is offline  
Old 04-12-2012, 05:27 PM
  #29  
Members
Thread Starter
 
Join Date: Aug 2011
Location: Springboro, OH
Posts: 79
Default

Originally Posted by tgm001 View Post
I`ve followed your instructions brendinernst, everything seems to work,I`ve paire my iphone with my car, but th only thing is that the car doesn`t sync my iphone contacts...so do you know how can I fix this

I`ve read somewhere that maybe I need to perform an update on the idrive..

what do you think


thanks
I acutally do as I had the same exact problem with my iPhone. You must go through your contacts and delete any "1" and "+" that are in front of your contacts phone number. DONE. They confuse your CCC.
brendinernst is offline  
Old 04-12-2012, 06:31 PM
  #30  
Members
Senior Members
 
Join Date: May 2011
Location: Montreal, QC
Posts: 271
My Ride: Bmw E60 530i 2004 Jet Black sport package on Linea Corse 19" Lc818 Saphire Black
Default

Originally Posted by brendinernst View Post
I acutally do as I had the same exact problem with my iPhone. You must go through your contacts and delete any "1" and "+" that are in front of your contacts phone number. DONE. They confuse your CCC.
I don't have navi, so I don't think my idrive is CCC, plus I just tried what you said and it didn't work !!

I can call and receive phone call and talk, I'm only having problem with downloading my contacts into the idrive !

I have an Iphone 4 with IOS 5.0.1 jailbreak..Do you think Idrive does not support IOS5? or the jailbreak? or something else ?

Thank you
tgm001 is offline  

Thread Tools
Search this Thread
Quick Reply: 03/04 to 08/04 BLUETOOTH CAN BE DONE WITH CODING! NO $$&


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.