6 Series Discussion A place for 6 series coupe, convertible, M6 owners and those curious.

Fixing problems and upgrading iDrive software

Old 12-07-2009, 06:58 AM
  #1  
Members
Thread Starter
 
Join Date: Dec 2009
Posts: 2
Default

Hello,

We have a constant issue with our 05 645i since it was bought. The Dynamic drive message comes on from time to time and it says it has a problem. The car is in spanish, i dont know exactly what the english message says but in Spanish its Control Dynamico Perturbado. After 9 visits to the dealership they havent been able to fix the problem. Also it displays the high battery discharge message from time to time. From what I understand these problems could possibly be fixed though a software upgrade. How do I know whats the latest version of software available and how tell if it has been changed when I ask them to do it at the dealership? Thanks! Located in Cancun Mexico.
MoeMonney is offline  
Old 12-07-2009, 09:43 AM
  #2  
Contributors
 
cobradav's Avatar
 
Join Date: Jun 2004
Location: FLA - East Coast, USA
Posts: 3,618
My Ride: (USA) 645Ci, Silver Gray, Chateau, Cold Weather PKG, Premium Sound PKG, Sport PKG, Step, NAV [Std Equip in 645], HUD, Satellite (SIRIUS) Radio, Aux Input, Bluetooth enabled using iPhone 3GS w/ adapter cradle - Build date - 01/05, Baby delivered 2/24/05
Default

Originally Posted by MoeMonney' post='1069242' date='Dec 7 2009, 10:58 AM
Hello,

We have a constant issue with our 05 645i since it was bought. The Dynamic drive message comes on from time to time and it says it has a problem. The car is in spanish, i dont know exactly what the english message says but in Spanish its Control Dynamico Perturbado. After 9 visits to the dealership they havent been able to fix the problem. Also it displays the high battery discharge message from time to time. From what I understand these problems could possibly be fixed though a software upgrade. How do I know whats the latest version of software available and how tell if it has been changed when I ask them to do it at the dealership? Thanks! Located in Cancun Mexico.
Latest is ISTA/P 2.35.4 released in mid November but I suspect there might be a newer version - but you dont really care. BMWAG recommends to its dealers worldwide that they only update using the newest version and in fact complained that USA dealers were slow to always use the newest. Have no idea how Mexican dealers deal with this but suspect they try to follow AG instructions.

Ask for a copy of the MEASURES Plan or FINAL Report. Either of these documents should give you the old and new versions, however they may use the Target Data Status numbers and not ISTA/P number (I think the new diagnostic software will print both but am not sure. In any case those numbers should be different and with a little translation we should be able to piece together the info on your previous version.

I am a little surprised your dealer says software issue, however, as it usually is a sensor or low hydraulic fluid for a Dynamic Drive issue. But maybe he saw something else.
cobradav is offline  
Old 12-08-2009, 05:03 PM
  #3  
Members
Thread Starter
 
Join Date: Dec 2009
Posts: 2
Default

Thank you very much for your help and detailed reply. I passed this information to the dealer and the main offices for BMW in Mexico and im waiting reply as to what they will be doing. Although the software may not be the issue with the dynamic drive i would still like them to upgrade to the newer iDrive software. Ill be updating soon.

Thanks Again!
MoeMonney is offline  
Old 12-08-2009, 06:57 PM
  #4  
Members
 
Join Date: Nov 2008
Posts: 167
Default

Originally Posted by cobradav' post='1069366' date='Dec 7 2009, 01:43 PM
Ask for a copy of the MEASURES Plan or FINAL Report. Either of these documents should give you the old and new versions, however they may use the Target Data Status numbers and not ISTA/P number (I think the new diagnostic software will print both but am not sure. In any case those numbers should be different and with a little translation we should be able to piece together the info on your previous version.
If I ask for a measures plan or Final report when I bring the car in for regular service (oil, etc), will it show the current version of software? Or does it only show it after a sofware upgrade?
kgmccarthy is offline  
Old 12-09-2009, 12:17 AM
  #5  
Contributors
 
tbal's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Posts: 4,508
My Ride: See sig :)
Default

Damn cobra, are you a bmw tech/sa?
tbal is offline  
Old 12-09-2009, 09:13 AM
  #6  
Contributors
 
cobradav's Avatar
 
Join Date: Jun 2004
Location: FLA - East Coast, USA
Posts: 3,618
My Ride: (USA) 645Ci, Silver Gray, Chateau, Cold Weather PKG, Premium Sound PKG, Sport PKG, Step, NAV [Std Equip in 645], HUD, Satellite (SIRIUS) Radio, Aux Input, Bluetooth enabled using iPhone 3GS w/ adapter cradle - Build date - 01/05, Baby delivered 2/24/05
Default

Originally Posted by kgmccarthy' post='1070611' date='Dec 8 2009, 10:57 PM
If I ask for a measures plan or Final report when I bring the car in for regular service (oil, etc), will it show the current version of software? Or does it only show it after a sofware upgrade?
Does not need to be a software change for these reports to say what version you have. But, if you are only in for oil change then very little chance of putting on diagnostic machine to get either of these reports. You really need a problem that would cause them to run diagnostic on your system.

I have samples of both on my car. By both, I mean reports when no change was made and those when a software update occured. I may post samples in my sticky on Service Bulletins in the Dealer Purchasing and Service section. Looks like I have not updated software list in about 6 months so I better do that as well.


Now if you bought you car new and have the build date, or you know the date of your last known software update we can get you an educated guess on your CIP / PROGMAN / ISTA/P level.
cobradav is offline  
Old 12-09-2009, 09:16 AM
  #7  
Contributors
 
cobradav's Avatar
 
Join Date: Jun 2004
Location: FLA - East Coast, USA
Posts: 3,618
My Ride: (USA) 645Ci, Silver Gray, Chateau, Cold Weather PKG, Premium Sound PKG, Sport PKG, Step, NAV [Std Equip in 645], HUD, Satellite (SIRIUS) Radio, Aux Input, Bluetooth enabled using iPhone 3GS w/ adapter cradle - Build date - 01/05, Baby delivered 2/24/05
Default

Originally Posted by tbal' post='1070740' date='Dec 9 2009, 04:17 AM
Damn cobra, are you a bmw tech/sa?
Nah, you know better than that. I just dug in a little like you do. I tend to work a lot with imbedded computer/software systems in large radar and telemetry space tracking systems and have always had an interest in software/hardware interaction.
cobradav is offline  
Old 12-11-2009, 12:20 AM
  #8  
Contributors
 
tbal's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Posts: 4,508
My Ride: See sig :)
Default

Wow your definantly a smart man!
tbal is offline  
Old 12-11-2009, 12:18 PM
  #9  
Senior Members
 
Join Date: Nov 2008
Location: Vancouver, Canada
Posts: 350
My Ride: 2003 760li
Default

Originally Posted by MoeMonney' post='1069242' date='Dec 7 2009, 07:58 AM
Hello,

We have a constant issue with our 05 645i since it was bought. The Dynamic drive message comes on from time to time and it says it has a problem. The car is in spanish, i dont know exactly what the english message says but in Spanish its Control Dynamico Perturbado. After 9 visits to the dealership they havent been able to fix the problem. Also it displays the high battery discharge message from time to time. From what I understand these problems could possibly be fixed though a software upgrade. How do I know whats the latest version of software available and how tell if it has been changed when I ask them to do it at the dealership? Thanks! Located in Cancun Mexico.
does it come on white your driving or turning hard? if so its not unheard of for the error to come up. the rearson why you get the error is if your turning hard the fluid for dynamic drive shifts which trips a sensor.
sunny_j is offline  
Old 12-14-2009, 08:16 PM
  #10  
Contributors
 
tbal's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Posts: 4,508
My Ride: See sig :)
Default

Thats happened to me a few times llol
tbal is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kasmo
E60 Discussion
22
05-07-2019 03:30 AM
andrek
E60 Discussion
3
03-26-2015 08:00 AM
Awest91
E60 Discussion
14
03-18-2015 02:26 AM
Guest
E60 Discussion
0
11-13-2003 06:07 PM
Litster
Dealer Purchasing & Service Forum
2
08-12-2003 11:41 AM


Thread Tools
Search this Thread
Quick Reply: Fixing problems and upgrading iDrive software


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.