SPRINT BOOSTER PROBLEM - 5Series.net - Forums

Go Back   5Series.net - Forums > E60 5 Series (2004 - 2010) > E60 Discussion

LinkBack Thread Tools Search this Thread
Old 08-04-2010, 08:59 AM   #1
Join Date: May 2010
Location: CROOKLYN
Posts: 3

Hello all,

I just installed a sprint booster in a 2007 550i SMG and I got this error message Engine Malfunction reduced power and a picture of an engine with half of it orange on my head up display.... any one know how to get rid of it? or any idea on what i did wrong?

Net is offline   Reply With Quote
Old 08-04-2010, 09:11 AM   #2
Senior Members

BlaSTiWi's Avatar
Join Date: Sep 2006
Location: Omaha, NE - USA
Posts: 3,236

Remove the SB annd see if it's the cause of the error ... then re-try but make sure the pin are correct ... it has to be in one particular orientation & don't bend any of them.


Heavily modded xi/xDrive/AWD
BlaSTiWi is offline   Reply With Quote
Old 08-04-2010, 09:31 AM   #3
Join Date: May 2010
Location: CROOKLYN
Posts: 3

I removed it the when i first installed it and it cleared up the error Ill check the pin alignment when i get home thx for your help.
Net is offline   Reply With Quote
Old 08-07-2010, 06:58 AM   #4
drosenth's Avatar
Join Date: Jan 2010
Location: Cicero, Indiana
Posts: 28

Not sure if this helps, but when I recently purchased mine I was asked for my transmission type so perhaps this comes into play (ie. your SB isn't for an SMG)...

Hope this helps,
drosenth is offline   Reply With Quote
Old 08-07-2010, 07:45 AM   #5
greycoopers's Avatar
Join Date: Apr 2010
Location: Rijswijk, The Netherlands
Posts: 578

Also make sure you leave the door open a couple of minutes after unlocking the car, before you remove the pedal. It said so in the manual. Of course I didn't read the manual, because guys don't do that Click the image to open in full size....and of course I got the error message...put everything back to oem, waited a couple minutes and did it the right way...no errors since then Click the image to open in full size.

2005 523exe | Orient Blue | M-Tech | Bi-Xenon | Black Kidneys | LED Angel Eyes | LED Side Markers | Carbon Emblems | Summer 20" Staggered ASA AR1 Wheels 9x20-10,5x20 ET18/26 | Winter Style 18" 123 wheels 8 x 18 ET20 | De-badged | Front Plate Delete | LED Plate Light | ITG Air Filter | Cobra Coils -30 mm | Black M Grill Badge | Sprint Booster V2 | RPi Scoop Red | OEM shadow Line Trim | Supersprint Exhaust | Sport / Comfort Black Leather | M5 Cluster Conversion
On order | Nothing :-)
Wish List | M5 BBK | M5 Trunk Finisher |

Gone | '07 Mini Cooper S | '05 BMW 745 High exe | '03 MB CLK 240 | '99 BMW 523 exe | the rest were not worthy...
greycoopers is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 550i tranny problems RussHamel73 E60 Discussion 6 06-03-2015 09:24 AM
WTB Sprint Booster Bank$hot530 Private Member Classifieds 1 04-27-2015 09:39 AM
HELP! Heavy white smoke out tailpipes Ė smells like gas (not coolant) thesalboy Other BMW Models 2 04-08-2015 10:13 AM
Need help can't change cluster and ccc's vin number bbbamboo E60 Discussion 0 04-08-2015 07:56 AM
E60 update and electrical system fixed E60Japanese E60 Discussion 4 03-23-2015 06:23 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -8. The time now is 04:24 PM.

All content Copyright © 2012 by Internet Brands, Inc.