Just bought an E60 -- can you help me solve all of these problems? - Page 3 - 5Series.net - Forums


Reply
 
 
 
Thread Tools Search this Thread
Old 01-05-2017, 04:37 PM   #21
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

Quote:
Originally Posted by amit1947 View Post
If you don't mind, how many miles does the car have and how much did you pay for it?
I paid $3300 and the car has 154k miles.
JPR10 is offline   Reply With Quote
Old 01-06-2017, 07:40 PM   #22
New Members

 
Join Date: Jul 2011
Location: Tampa, FL
Posts: 630
Default

any pc will work. I have it working on a laptop from 2003 with windows 7
seanjordan20 is offline   Reply With Quote
Old 01-07-2017, 08:30 PM   #23
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

So I saw smoke coming from my engine bay -- confirming oil pan leak I think... Bought a new pan gasket, but don't have the space/tools to do this job. What is a fair price to pay an indy to do this? I understand they have to drop the subframe, which makes this job a huge PITA.

Also -- cleaned the MAF, replaced the air filter which was filthy. It didn't improve MPG as much -- I want to check the DISA valve next, to see if it is failing. Any other thoughts?

Maybe resetting some adaptations via INPA? Which modules/adaptations should I reset?




Let me know what you guys think.
JPR10 is offline   Reply With Quote
Old 01-08-2017, 11:32 AM   #24
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

Also -- I can't seem to find a definitive post on cleaning/unclogging the sunroof drains. I have water pooled up in my battery well.

Can anyone point me in the right direction?
JPR10 is offline   Reply With Quote
Old 01-09-2017, 09:13 PM   #25
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

trying to install INPA -- except for I'm not able to install EDIABAS... Has anyone run into this issue?

JPR10 is offline   Reply With Quote
Old 01-11-2017, 03:57 PM   #26
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

So it looks like the disc I got from eBay was an incomplete version of INPA... I have since found an installation for EDIABAS... Will work on it this weekend...

I hear wind noise through the windshield at freeway speeds... What is the likely culprit for this?

Also -- will be servicing the transmission Friday, doing pan/filter and fluid -- then resetting adaptations.

Will report back on how the car is running.
JPR10 is offline   Reply With Quote
Old 01-11-2017, 06:56 PM   #27
New Members
 
brewmasterflash's Avatar
 
Join Date: Sep 2014
Location: San Francisco Bay Area
Posts: 27
Default

The sunroof drains are in the rear wheel well behind the cover. Cleaned mine on my 04 525 so should be same location. its a little plus sign, cut mine back so it wouldn't clog. Shouldn't be hard to find a few threads on this.

Are you sure your oil pan leak is in fact and oil pan leak and not the oil filter housing gasket? My ofhg leak sure looked like an oil pan leak until I fixed it and now it's all dry down there. I would be damn sure before I do the pan gasket and even then would probably just not do it lol.
brewmasterflash is offline   Reply With Quote
Old 01-11-2017, 09:49 PM   #28
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

Quote:
Originally Posted by brewmasterflash View Post
The sunroof drains are in the rear wheel well behind the cover. Cleaned mine on my 04 525 so should be same location. its a little plus sign, cut mine back so it wouldn't clog. Shouldn't be hard to find a few threads on this.

Are you sure your oil pan leak is in fact and oil pan leak and not the oil filter housing gasket? My ofhg leak sure looked like an oil pan leak until I fixed it and now it's all dry down there. I would be damn sure before I do the pan gasket and even then would probably just not do it lol.
For the drains, it's a tube that goes into a rubber grommet that is placed into the metal right? Did you just remove it? Does anything need to be done under the fender liners?

As for the leak, BMW said that it was the pan gasket -- but I'm not convinced. After a short drive, I can smell burnt oil, and some steam coming from the back of the motor. It looks like it's coming from the exhaust manifold -- so I'm thinking a valve cover gasket.

I'm having my Indy service my transmission on Friday so I'll tell him to inspect for any other visible leaks...

On another note... I took her for a drive today and realized that there is not a lot of low end torque... Is this a symptom of a failing DISA valve? I'm already getting shitty MPG. Your thoughts?

Let me know what you think.
JPR10 is offline   Reply With Quote
Old 01-12-2017, 05:55 AM   #29
New Members
 
brewmasterflash's Avatar
 
Join Date: Sep 2014
Location: San Francisco Bay Area
Posts: 27
Default

Yes, for the drains it's just the grommet at the end that usually plugs up. I did blow some air through it too. You could also push some wire through it. Nothing too firm, something like the plastic wire from a weed trimmer.

Valve cover gasket also a more likely culprit.
brewmasterflash is offline   Reply With Quote
Old 01-12-2017, 01:01 PM   #30
New Members
Thread Starter

 
Join Date: Dec 2016
Location: San Jose
Posts: 44
Default

Quote:
Originally Posted by brewmasterflash View Post
Yes, for the drains it's just the grommet at the end that usually plugs up. I did blow some air through it too. You could also push some wire through it. Nothing too firm, something like the plastic wire from a weed trimmer.

Valve cover gasket also a more likely culprit.
I'll take a look at the drains and let you know if I run into any problems.

Dropped my car off at my Indy over lunch -- he'll be tackling the pan/filter and fluid, valve cover gasket, oil change. He also had a spare DISA valve that he's going to try on my car -- my old one rattles, and is likely on its way out.

He doesn't have any of the BMW Standard Tools coding software, so I'm going to make sure I can get EDIABAS installed on my machine tonight, so I can reset adaptations first thing in the morning tomorrow.

Will report back on how the car is driving. I hope the new DISA helps drivability issues, mpg issues -- and that the tranny service helps smooth out some shifting.

He will also be using an SRS scan tool to check any airbag fault codes.
JPR10 is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 10:14 PM.


All content Copyright 2012 by Internet Brands, Inc.