Upgraded from 2003 built TCU to 2007TCU & after flashing to new VIN No more BT ?? - 5Series.net - Forums


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 12-08-2016, 06:07 PM   #1
New Members
Thread Starter

 
cmyachtie's Avatar
 
Join Date: Sep 2012
Location: Halifax, Nova Scotia, Canada
Posts: 323
Default Upgraded from 2003 built TCU to 2007TCU & after flashing to new VIN No more BT ??

OK, have a Winkfp question used it for first time yesterday to flash my vin to my 2007 TCU I just replaced my original 2003 version with that came with the car to get full BT Phone capability.
after installing the new (to me) TCU a few days ago it was providing me with BT phone functionality, did get a recurring fault code about airbag #A375 (Error IBUS Connection fail)

Assumed that was maybe because of the VIN mismatch now the vin from my car is showing up in INPA (took over an hour to flash last night).
however cannot activate BT anymore in iDrive the function shows as before (not greyed or anything) just won't accept my check mark to activate.....

since the VIN WRITE got also the following faults:
A391 (error TCU Main antenna)
A379 (error BT interface)

cleared those errors and the the only one that keeps recurring is the A375


So when Winkfp rewrites the VIN what else happens ??
any ideas why why this happened or what I can do to correct?

Thanks

UPDATE:
So since no one seems to have any ides on what ....kept on plugging away at it and decided to do some coding to the TCU, which my logical thinking considered to be a long shot since it worked before withe coding it had and to my surprise, it's back to where it should be, steering wheel buttons work, phonebook is in iDrive and am able to select BT and make calls......

Just don't think will ever understand some of the BMW logic.......LOL
will attach the TCU trace file(just rename the pdf to trc) for those in need, I know there are several out there but some we can't tell which continent there from
Attached Thumbnails
Upgraded from 2003 built TCU to 2007TCU & after flashing to new VIN No more BT ??-img_6253.jpg  
Attached Files
File Type: pdf WORKING TCU CODED FSW_PSW.pdf (15.1 KB, 9 views)

Last edited by cmyachtie; 12-09-2016 at 08:47 AM. Reason: FIXED!!!!
cmyachtie is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:41 AM.


All content Copyright 2012 by Internet Brands, Inc.